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Introduction
Thank you for purchasing the ZiLOG ZGP32300200ZPR Z8 GP™ ZGP323 Programming 
System with USB interface (Figure 1). The Z8 GP™ ZGP323 Programming System pro-
vides an inexpensive development environment for ZiLOG’s Z8 GP family of microcon-
trollers. Two windowed 28-CDIP (Ceramic DIP) chips are included for use in prototyping. 
The windowed CDIP chips are provided for your convenience and are eraseable with 
ultraviolet light.

This User Manual tells you how to connect programming system components to your PC, 
and a target board, install the ZDSII integrated development environment, and use ZDSII 
to burn demonstration code into a Z8 GP family OTP microcontroller.

Figure 1. Z8 GP ZGP323 Programming System with USB Interface
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Software Requirements
Table 1 lists the PC requirements for running ZDS II.

Installing the ZDSII Software
Perform the following steps to install the software tools:

1. Load the ZDSII CD into your CD-ROM drive.

2. The CD automatically launches the DemoShield application and provides a menu to in-
stall the product and documentation. Click on the Install Application button and follow 
the prompts to install ZDS II.

Software versions illustrated in the following figures are for reference only. 
You may have an updated version.

3. The following directory is installed on the host PC, assuming all installation settings 
remain at their defaults:
C:\Program Files\ZiLOG\ZDSII_<product>_<version number>.

Configuring the 5VDC Universal Power Supply
The universal power supply kit features several different plug configurations in one box 
and the power supply itself in another. The power supply ships with a slide-out plate that 
must be removed to insert the location-specific plug configurations.
1. Remove the slide-out plate.

Table 1. ZDS II System Requirements

Recommended Configuration Minimum Configuration
• PC running MS Windows XP, SP2
• Pentium III/500 MHz processor
• 128 MB RAM
• 35 MB hard disk space
• Super VGA video adapter
• CD-ROM drive
• USB port
• Internet browser (Internet Explorer or 

Netscape)

• PC running MS Windows 98SE/WinNT 4.0–
SP6/Win2000–SP3/WinXP–SP1

• Pentium II/233 MHz processor
• 96 MB RAM
• 12 MB hard disk space (documentation not 

included)
• Super VGA video adapter
• CD-ROM drive
• USB port
• Internet browser (Internet Explorer or 

Netscape)

Note:
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2. Select the plug configuration specific to the power requirements of your locale and 
insert it into the slot that remains after removing the slide-out plate.

3. Slide the new plug configuration into the slot until it snaps into place.
4. Plug the power supply into an electrical outlet.

Installing the USB Interface Driver and Cable
The Z8 GP ZGP323 Programming System features a USB interface. Follow the steps in 
this section to install the Z8 GP ZGP323 Programming System with USB Interface and 
configure the Z8 Programmer. Connect the hardware as shown in Figure 2.

Figure 2. Hardware Setup Using the Supplied USB Cable

When you first connect the Programming System to your computer, you need to help Win-
dows load the appropriate driver from the ZDSII installation directory or CD-ROM. You 
can download ZDSII software from www.ZiLOG.com. You need to help Windows locate 
the driver once only. The procedure you use depends on your Windows operating system 
version. 

Windows XP
1. Connect the 5 VDC power supply to the Programming System and apply power.
2. Connect the Programming System to the host PC using the USB cable.

If the Found New Hardware Wizard window appears, check the No, not this time but-
ton and click Next to continue.

3. In the Wizard, select Install from a list or specific location (Advanced); then click Next.

If the Windows Logo testing dialog appears, select Continue Anyway.Note:
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4. Select Search for the best driver in these locations and Include this location in search.
5. Browse to the driver directory, one of the following:

<ZDSII Installation Directory>\device drivers\USB
<ZDSII Installation CD>\Device Drivers\USB

6. Click Next, and then click Next again after the appropriate driver is found.
7. Click Finish to complete the installation.

Windows 2000
1. Connect the 5 VDC power supply to the Programming System and apply power.
2. Connect the Programming System to the host PC using the USB cable.

The Found New Hardware Wizard should activate automatically.
3. In the Wizard, click Next.
4. Select Search for a suitable driver for my device (Recommended); then click Next.

5. Select Specify a location; then click Next.
6. Browse to the driver directory, one of the following:

<ZDSII Installation Directory>\device drivers\USB
<ZDSII Installation CD>\Device Drivers\USB

7. Click OK, and then click Next after the appropriate driver is found.
8. Click Finish to complete the installation.

Windows 98SE
1. Connect the 5 VDC power supply to the Programming System and apply power.
2. Connect the Programming System to the host PC using the USB cable.

The Found New Hardware Wizard should activate automatically.
3. In the Wizard, click Next.
4. Select Search for the best driver for your device (Recommended); then click Next.
5. Select Specify a location; then browse to the driver directory, one of the following:

<ZDSII Installation Directory>\device drivers\USB
<ZDSII Installation CD>\Device Drivers\USB

6. Click Next, and then click Next again after the appropriate driver is found.
7. Click Finish to complete the installation.
Installing the USB Interface Driver and Cable UM019101-0305
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Programming System Components
The Z8 GP ZGP323 Programming System circuit board contains three LED indicators:
• Yellow LED D1: Flashes as data is received over the USB connection from the PC.
• Red LED D3: Illuminates during OTP programming or reading.
• Green LED D5: Illuminates when 5VDC is applied to the programmer.

The following components are for factory use only:
• Jumper JP1, which must be IN.
• Jumpers JP2 through JP7.
• Connector P1 (ZDI).
• Header J1 (ISP).
• Test points TP1 and TP2.

The remaining components are not user-serviceable.

Using ZDS II to Burn a Hex File into a ZGP323 OTP Chip
After installing the ZDS II software and setting up the hardware, use the following proce-
dure to open the sample project named ledblink_c.pro, build a hex file from the pro-
gram, and burn that hex file into the supplied ZGP323 28-CDIP chip via the OTP 
programming module.

If you are familiar with using ZDS II to create hex files and have previously 
used the Z8 GP ZGP323 programming system, refer to “Hex File Burning 
Instructions for Experienced ZDS II Users” on page 9

The sample project ledblink_c.pro is included in the ZDS II sample directory, located 
in:

c:\Program Files\ZiLOG\ZDSII_<product>_<version>
  \samples\<processor type>_<demo name>

\<demo name>_<language>\src

1. Start ZDS II for the Z8 GP ZGP323 programming system.

2. Open the sample project file: File –> Open Project –> 
c:\Program Files\ZDSII_Z8GP_<version>
\samples\ZGP323_ledBlink\ledblink_c\src\ledblink_c.pro.

3. In ZDSII, open the Build menu and select Set Active Configuration.

Note:
UM019101-0305
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4. In the Select Configuration dialog, select Debug and click OK.

5. Open Project –> Settings.

6. In the General tab, verify the CPU Family field is set to ZGP323.

7. In the General tab, set the CPU field to ZGP323XXX2832_Window.

8. Set the Output Files Directory: to the directory in which you want your output files 
stored. By default, ZDSII stores your files in the same directory as the project files.

9. In the Debugger tab, make sure the Driver: field is set to Simulator.

10. Click OK.

11. When asked to rebuild affected files, click Yes to rebuild the project. (You can also re-
build later by pressing F7.)

The Build Output Window at the bottom of ZDSII provides status messages about the 
rebuild’s progress.

12. To debug the program using the simulator, open the Build menu and select Debug and 
then Reset to load the simulator with the program code. The simulator is used to com-
pletely debug the program before downloading to the chip. Select Build > Debugger > 
Stop Debugging when you have finished debugging.

13. Now that the program is complete, we’re going to create a hex file you can download 
into a ZGP323 chip installed on the Programing System.

14. In ZDSII, open the Build menu and select Set Active Configuration.

15. In the Select Configuration dialog, select Release and click OK.

16. Rebuild the project. Open the Build menu and select Rebuild All.

17. Browse to the c:\Program Files\ZDSII_Z8GP_<version>
\samples\ZGP323_ledBlink\ledblink_c\src directory. There you will find 
the file ledblink_c.hex, the hex file just created when you rebuilt the project in Re-
lease configuration.

18. Connect the Z8 GP ZGP323 programming system to your development PC as de-
scribed in “Installing the USB Interface Driver and Cable” on page 3.

19. Open Project > Settings.

The Project Settings window appears.
Using ZDS II to Burn a Hex File into a ZGP323 OTP Chip UM019101-0305



Z8 GP™ ZGP323 Programming System
User Manual

Page 7
20. In the Debugger tab of the Project Settings window, select USB Driver from the Driver 
drop-down menu.

21. Click OK. If prompted to rebuild the project, click YES.

22. Select the appropriate package converter for the OTP chip you wish to burn. For the 
windowed 28-CDIP part, select the 28-PDIP package converter.

23. Install the package converter into the ZIF socket on the Programming System. Match 
pin 1 of the package converter with pin 1 of the ZIF socket. Pin numbers are silk-
screened on the board.

24. Install the OTP chip you wish to burn into the package converter installed on the Pro-
gramming System’s ZIF socket. Match pin 1 of the chip (indicated by a notch on the 
chip) with pin 1 of the package converter’s ZIF socket.

25. Stop any current debugging process by selecting Build > Debug > Stop Debugging.

26. Select Tools > OTP Programming to open the OTP window (Figure 3).
UM019101-0305 Using ZDS II to Burn a Hex File into a ZGP323 OTP Chip
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Figure 3. OTP Programming Window (Hex File Example)

27. If the appropriate target device is not selected, set it now in the Device drop-down 
menu. For the windowed ZGP323 part shipped with the programming system, select 
ZGP323XXX2832_Window.

28. In the Hex File: section, click the  button and select the hex file you wish to burn 
into the OTP chip.

29. If you do not want to pad the hex file, select the None button in the Pad File With area. 
Otherwise, select the FF, 00, or Other button. If you select the Other button, type the 
hex value to pad the hex file with in the Other field.

30. Click the Load File button to load the hex file.

31. Click the Ram Checksum button to calculate the checksum of the data in programmer 
RAM. Use this to compare with the OTP checksum after burning.

32. Select which option bits to program in the Programming Option Bits area. For this demo 
example, no option bits need to be added.

33. If you do not want a serial number loaded into the part, select the None button in the 
Method area. For this demo example, select None. To load a serial number:
a. Select the Sequential or Pseudorandom button to determine how the serial number 

is incremented on subsequent burns.
b. Select the size of the serial number (1, 2, 3, or 4 bytes) in the Serial Number Size 

area.
c. Enter the starting serial number in the Serial Number field.
d. Enter the address into which you want the serial number loaded in the Address 

field. Consult the project’s MAP file to determine an unused memory location.
34. Click Blank Check to verify that the OTP chip is actually blank.

35. Click the Burn button to program the OTP chip with the contents of programmer RAM. 
As part of the Burn function, the OTP chip is also verified.

36. When the burn is complete, click OTP Checksum to calculate the checksum of data on 
the OTP chip and compare it to the RAM checksum calculated earlier.

37. Click Close to close the OTP Programming window. You now have a chip that is ready 
to be used on a target board.
Using ZDS II to Burn a Hex File into a ZGP323 OTP Chip UM019101-0305
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Hex File Burning Instructions for Experienced ZDS II Users
The following instructions describe the process for burning a hex file to a ZGP323 OTP 
chip.
1. Connect the Z8 GP ZGP323 Programming System to your development PC as 

described in “Installing the USB Interface Driver and Cable” on page 3.
2. Install the appropriate package converter into the ZIF socket on the Programming Sys-

tem.
3. Install the OTP chip you wish to burn into the package converter installed in the Pro-

gramming System’s ZIF socket. Match pin 1 of the chip with pin 1 of the package con-
verter’s ZIF socket.

4. Stop any current debugging process by selecting Build > Debug > Stop Debugging.
5. In ZDS II, open any project, such as ledblink_c.pro located in 

c:\Program Files\ZDSII_Z8GP_<version>
\samples\ZGP323_ledBlink\ledblink_c\src\ledblink_c.pro.

6. In the Debugger tab of the Project Settings window, select USB driver from the drop-
down menu.

7. Select Tools > OTP Programming to open the OTP window (Figure 4).
UM019101-0305 Hex File Burning Instructions for Experienced ZDS II Users
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Figure 4. OTP Programming Window (Hex File Example)

8. If the appropriate target device is not selected, set it now in the Device drop-down 
menu.

9. In the Hex File: section, click the  button and select the hex file you wish to burn 
into the OTP chip.

10. Set the remaining OTP programming parameters as necessary for your application.
11. Click the Load File button to load the hex file.
12. Click the Burn button to program the OTP chip with the contents of programmer RAM 

and selected options.
Hex File Burning Instructions for Experienced ZDS II Users UM019101-0305
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This publication is subject to replacement by a later edition. To determine whether a later 
edition exists, or to request copies of publications, contact:

ZiLOG Worldwide Headquarters
532 Race Street
San Jose, CA 95126
Telephone: 408.558.8500
Fax: 408.558.8300
www.ZiLOG.com

Document Disclaimer
ZiLOG is a registered trademark of ZiLOG Inc. in the United States and in other countries. All
other products and/or service names mentioned herein may be trademarks of the companies with
which they are associated.

©2005 by ZiLOG, Inc. All rights reserved. Information in this publication concerning the devices,
applications, or technology described is intended to suggest possible uses and may be superseded.
ZiLOG, INC. DOES NOT ASSUME LIABILITY FOR OR PROVIDE A REPRESENTATION OF
ACCURACY OF THE INFORMATION, DEVICES, OR TECHNOLOGY DESCRIBED IN THIS
DOCUMENT. ZiLOG ALSO DOES NOT ASSUME LIABILITY FOR INTELLECTUAL PROP-
ERTY INFRINGEMENT RELATED IN ANY MANNER TO USE OF INFORMATION,
DEVICES, OR TECHNOLOGY DESCRIBED HEREIN OR OTHERWISE. Devices sold by
ZiLOG, Inc. are covered by warranty and limitation of liability provisions appearing in the ZiLOG,
Inc. Terms and Conditions of Sale. ZiLOG, Inc. makes no warranty of merchantability or fitness for
any purpose Except with the express written approval of ZiLOG, use of information, devices, or
technology as critical components of life support systems is not authorized. No licenses are con-
veyed, implicitly or otherwise, by this document under any intellectual property rights.
UM019101-0305 Hex File Burning Instructions for Experienced ZDS II Users

http://www.ZiLOG.com

	Introduction
	Software Requirements
	Installing the ZDS II Software
	Configuring the 5VDC Universal Power Supply
	Installing the USB Interface Driver and Cable
	Windows XP
	Windows 2000
	Windows 98SE

	Programming System Components
	Using ZDS II to Burn a Hex File into a ZGP323 OTP Chip
	Hex File Burning Instructions for Experienced ZDS II Users
	ZGP32300200ZPR
	Z8 GP™ ZGP323 Programming System with USB Interface


<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /SyntheticBoldness 1.00
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /FRA <>
    /ENU (Use these settings to create PDF documents with higher image resolution for improved printing quality. The PDF documents can be opened with Acrobat and Reader 5.0 and later.)
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308000200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e30593002537052376642306e753b8cea3092670059279650306b4fdd306430533068304c3067304d307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e30593002>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
  >>
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


